yarn的使用及升级Node.js的新方法

2017-05-07

yarn的使用

yarn包管理工具,官网说是快速、可靠、安全的依赖管理,尝试了一下,入手很快,用起来也蛮方便的。大家可以尝试一下。

yarn安装

mac电脑上面安装如下:

brew update

brew install yarn

yarn工作流

1、创建一个新的项目

yarn init

类似于npm init ,package.json的配置

2、添加依赖项

yarn add [package]

类似于npm install

3、安装依赖项

安装所有依赖:yarn 或 yarn install

安装一个包的单一版本:yarn install --flat

强制重新下载所有包:yarn install --force

只安装生产环境依赖:yarn install --production

yarn和npm的命令对照

具体可以查看:https://yarnpkg.com/zh-Hans/docs/migrating-from-npm

yarn的cli命令介绍

具体可以查看:https://yarnpkg.com/zh-Hans/docs/cli/

yarn config设置镜像

我之前写过npm国内镜像,npm安装失败解决方案,我们也可以通过yarn的config来设置淘宝镜像, 相关命令如下:

yarn config list

列出路径

yarn config set registry http://registry.npm.taobao.org/

设置淘宝镜像。

升级Node.js的新方法

当我运用

yarn add webpack

的时候,提示:

error [email protected]: The engine "node" is incompatible with this module. Expected version ">=4.3.0 <5.0.0 || >=5.10".
error Found incompatible module

说我的nodejs版本太老了。如何在mac中轻松升级nodejs呢?方法如下:

可以使用npm或者yarn安装n工具包,步骤如下:

sudo npm cache clean -f
sudo npm install -g n
sudo n stable

这样nodejs就升级到最新稳定版了!

n 是一个Node工具包,它提供了几个升级命令参数:

n                              显示已安装的Node版本
n latest                       安装最新版本Node
n stable                       安装最新稳定版Node
n lts                          安装最新长期维护版(lts)Node
n <version>                    根据提供的版本号安装Node

http://www.thinksaas.cn/news/0/47/47565.html
用户评论
开源开发学习小组列表