[Linux] PHP程序员玩转Linux系列-升级PHP到PHP7

q36568587

q36568587

发表于 2017-04-14 21:37:30

1.PHP程序员玩转Linux系列-怎么安装使用CentOS

2.PHP程序员玩转Linux系列-lnmp环境的搭建

3.PHP程序员玩转Linux系列-搭建FTP代码开发环境

4.PHP程序员玩转Linux系列-备份还原MySQL

5.PHP程序员玩转Linux系列-自动备份与SVN

6.PHP程序员玩转Linux系列-Linux和Windows安装nginx

7.PHP程序员玩转Linux系列-nginx初学者引导

8.PHP程序员玩转Linux系列-Nginx中的HTTPS

9.PHP程序员玩转Linux系列-使用supervisor实现守护进程

 

在系列的第二篇,CentOS系统下lnmp环境搭建中,我安装好的PHP版本是5.3,现在我要用最简单的方式升级PHP版本到最新版.

访问这个网站https://webtatic.com/,该网站提供PHP最新版本的yum仓库,直接拿来就能用,非常的方便. 

添加仓库

rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-6.noarch.rpm
rpm -Uvh https://mirror.webtatic.com/yum/el6/latest.rpm

安装PHP7

yum install php71w* 

nginx,mysql,php的版本情况

 

安装PHP的memcached扩展,该扩展是memcache扩展的改进版

pecl install msgpack
pecl install memcached

该扩展必须的依赖是:libmemcached 1.x 或更高;igbinary扩展 2.0或更高;msgpack 2.0或更高

如果要安装libmemcached这个客户端库,需要编译安装,如果有需要再写写过程.  

新加个配置文件/etc/php.d/memcached.ini,里面就一句话

extension=memcached.so

  

 

nginx与php-fpm的测试

 

mysql的链接测试

$dbh = new PDO("mysql:host=localhost;dbname=blog","root","xxxx");
$sth = $dbh->prepare("select * from article");
$sth->execute();
$result = $sth->fetchAll(PDO::FETCH_COLUMN);
var_dump($result);

 

memcache的链接测试

$m = new Memcached();
$m->addServer('localhost', 11211);

$m->set('name', "taoshihan");
var_dump($m->get('name'));                             

 

  

相关帖子
用户评论
开源开发学习小组列表